找到你要的答案

Q:How can I know what requires yum to install those dependencies?

Q:我怎么能知道需要yum安装那些依赖?

Doing yum update I get the following:

 kernel-modules-extra              x86_64 3.18.7-100.fc20                       @updates/20
                                                                                        8.3 M
Installing for dependencies:
 GeoIP-GeoLite-data                noarch 2015.04-1.fc21                        updates 347 k
 GeoIP-GeoLite-data-extra          noarch 2015.04-1.fc21                        updates  23 M
 R-core                            x86_64 3.1.3-1.fc21                          updates  48 M
 R-core-devel                      x86_64 3.1.3-1.fc21                          updates 100 k
 dleyna-connector-dbus             x86_64 0.2.0-4.fc21                          updates  24 k
 dleyna-core                       x86_64 0.4.0-3.fc21                          fedora   30 k
 dleyna-server                     x86_64 0.4.0-7.fc21                          updates  70 k
 geoipupdate                       x86_64 2.2.1-2.fc21                          updates  33 k
 lz4                               x86_64 r128-2.fc21                           updates  68 k

I want to know what requires R-core as i built it myself and do not want it to be installed... There must be something I must delete...

做更新升级我得到以下:

 kernel-modules-extra              x86_64 3.18.7-100.fc20                       @updates/20
                                                                                        8.3 M
Installing for dependencies:
 GeoIP-GeoLite-data                noarch 2015.04-1.fc21                        updates 347 k
 GeoIP-GeoLite-data-extra          noarch 2015.04-1.fc21                        updates  23 M
 R-core                            x86_64 3.1.3-1.fc21                          updates  48 M
 R-core-devel                      x86_64 3.1.3-1.fc21                          updates 100 k
 dleyna-connector-dbus             x86_64 0.2.0-4.fc21                          updates  24 k
 dleyna-core                       x86_64 0.4.0-3.fc21                          fedora   30 k
 dleyna-server                     x86_64 0.4.0-7.fc21                          updates  70 k
 geoipupdate                       x86_64 2.2.1-2.fc21                          updates  33 k
 lz4                               x86_64 r128-2.fc21                           updates  68 k

我想知道需要R型为我自己建造的,不希望它被安装…一定有我必须删除的东西…

answer1: 回答1:

rpm -q --whatrequires R-core might tell you.

If it doesn't it might be a library or binary dependency and so you'll need to run yum whatrequires on the various libraries/binaries listed in the output from rpm -q --provides R-core and/or rpm -ql R-core.

That being said the fact that you built R yourself isn't going to help you in this case as rpm doesn't know anything about that (nor is it likely to be installed in a location that official Fedora packages can use).

If you were to build R as an rpm yourself you might be able to get that to satisfy this dependency (whatever it is) correctly though.

转- Q whatrequires R型可能会告诉你的。

如果它不可能是一个图书馆或二进制的依赖,所以你需要运行yum whatrequires各种/双星图书馆列在输出转速-问了R型和/或转- QL R型。

也就是说事实上你建立R自己不会帮你在这种情况下,转速不知道(也不可能被安装在一个位置,官方的Fedora包可以使用)。

如果你建立R作为RPM自己,你可能能够得到,以满足这种依赖(无论是)正确,虽然。

linux  dependencies  yum  fedora-21