找到你要的答案

Q:WordPress with SQLite Integration Plugin

Q:SQLite集成插件WordPress

just downloaded wordpress-4.1.2.zip and sqlite-integration.1.8.1.zip and unzipped them locally in a system with the following specifications:

  • Apache: Apache/2.4.7 (Ubuntu)
  • PHP: 5.5.9-1ubuntu4.9
  • php5-sqlite: 5.5.9+dfsg-1ubuntu4.9

I stored sqlite-integration folder in plugins folder, and moved db.php file to wp-content folder and generated the required keys... The result was this message:

PDO Driver for SQLite is missing. Your PHP installtion appears not to have the right PDO drivers loaded. These are required for this version of WordPress and the type of database you have specified.

Did I miss something?

Thanks in advance for the help.

刚刚下载wordpress-4.1.2.zip和sqlite-integration.1.8.1.zip和解压在系统具有以下规格:

  • Apache: Apache/2.4.7 (Ubuntu)
  • PHP: 5.5.9-1ubuntu4.9
  • php5-sqlite: 5.5.9+dfsg-1ubuntu4.9

I s到red sqlite-integration folder in plugins folder, and moved db.php file 到 wp-content folder and generated the required keys... The result was this message:

PDO Driver for SQLite is missing. Your PHP installtion appears not 到 have the right PDO drivers loaded. These are required for this version of WordPress and the type of database you have specified.

我错过什么了吗?

提前感谢帮助。

answer1: 回答1:

Your host does not have PDO extension enabled in php.ini, please do enable them to avoid this error.

check this link to see how you can enable the extension:

http://php.net/manual/it/pdo.installation.php

On unix based systems if you don't have ssh access you should remove ; in php.ini before :

;extension=pdo.so

to

extension=pdo.so

if you didn't find the above lines in php.ini add them and remember to restart your server.

extension=pdo.so
extension=pdo_mysql.so

or follow the terminal :

sudo apt-get install php5-gd php5-mysql

else you can follow the answer of @christian-nguyen

你的主机没有PDO扩展在php.ini中启用,请使他们能够避免这个错误。

检查此链接以查看如何启用扩展:

http://php.net/manual/it/pdo.installation.php

在基于Unix的系统上,如果你没有SSH访问你要去除;在php.ini中前:

;extension=pdo.so

extension=pdo.so

if you didn't find the above lines in php.ini add them and remember 到 restart your server.

extension=pdo.so
extension=pdo_mysql.so

或跟随终端:

sudo apt-get install php5-gd php5-mysql

你还可以按照“基督教阮答案

answer2: 回答2:

Just install php5-sqlite:

sudo apt-get install php5-sqlite

只要安装PHP5 SQLite:

sudo apt-get install php5-sqlite
linux  wordpress  sqlite  ubuntu  pdo